fix(deps): upgrade mocha to 12.0.0-beta-10 for serialize-javascript 7.x
Mocha 11.x still depends on serialize-javascript ^6.0.2 (vulnerable). Remove npm overrides; use Mocha 12 beta which pulls serialize-javascript ^7.0.2 (resolves to 7.0.5, fixing Dependabot alert #94). Resolves GHSA-5c6j-r48x-rmvq. Co-authored-by: Daniel Imms <Tyriar@users.noreply.github.com>
This commit is contained in:
co-authored by
Daniel Imms
parent
9269f02353
commit
a7592068a2
+1
-4
@@ -99,7 +99,7 @@
|
||||
"express": "^5.2.1",
|
||||
"express-ws": "^5.0.2",
|
||||
"jsdom": "^29.1.1",
|
||||
"mocha": "^11.7.5",
|
||||
"mocha": "12.0.0-beta-10",
|
||||
"mustache": "^4.2.0",
|
||||
"node-pty": "^1.2.0-beta.9",
|
||||
"nyc": "^18.0.0",
|
||||
@@ -115,8 +115,5 @@
|
||||
"webpack-cli": "^7.0.2",
|
||||
"ws": "^8.20.0",
|
||||
"xterm-benchmark": "^0.3.2"
|
||||
},
|
||||
"overrides": {
|
||||
"serialize-javascript": "^7.0.5"
|
||||
}
|
||||
}
|
||||
|
||||
Reference in New Issue
Block a user